www.BinaryAlchemy.de :: View topic - Help my Bounding box is casting a semitransparent shadow.
 SearchSearch   RegisterRegister  ProfileProfile   UsergroupsUsergroups   Log inLog in 
If you create a new post, please use a topic that describes your problem
Documento sin título
 
Help my Bounding box is casting a semitransparent shadow.

 
Post new topic   Reply to topic    www.BinaryAlchemy.de Forum Index -> Shader Problems / How do I...?
View previous topic :: View next topic  
Author Message

grahamc



Joined: 27 Apr 2009
Posts: 20
Location/Company/Country: Red Vision, Manchester, UK

PostPosted: Thu Apr 30, 2009 5:29 pm    Post subject: Help my Bounding box is casting a semitransparent shadow. Reply with quote

Can anyone help?
I have folowed the video tutorial in maya 2009 to set up a volume shader. I then added a ground plain into the shot and I am getting semitransparent shadows casting from the boundingbox. I have assigned a transparent lambert to the render geo and I have hidden the particles also. I am using a raytraced light.

Another problem! I have cached 250 frames in my maya scene but I can only render the volume upto frame 200. It just disappears at frame 201 and beyond... I have deleted the PT_loader and tried creating a new one, but I still get the same error. The cache plays back fine in maya upto frame 250.

Thanks for any help

Graham
Back to top
View user's profile Send private message Visit poster's website

schoenberger
Site Admin


Joined: 02 Mar 2005
Posts: 3786

PostPosted: Thu Apr 30, 2009 7:20 pm    Post subject: Reply with quote

About the cache: Please check the sequence settings in the PT_loader.

Please disconnect the shader, do you still get shadows without the volume?
Then it is the lambert material or a shadow raytracing settings (check the ray depths in the Mray render settings )
_________________
Holger Schönberger
Binary Alchemy - digital materialization
Back to top
View user's profile Send private message Send e-mail

grahamc



Joined: 27 Apr 2009
Posts: 20
Location/Company/Country: Red Vision, Manchester, UK

PostPosted: Fri May 01, 2009 8:43 am    Post subject: Reply with quote

If I disconect the volume shader I still get the BB shadows. I have tried increasing the ray tracing depth but it still made no difference. I have also tried putting a ground plane into the PT_Textured sample scene and I get the same problem with the BB casting shadows.

I have fixed the cache, the settings were not picking the correct endframe.

G
Back to top
View user's profile Send private message Visit poster's website

grahamc



Joined: 27 Apr 2009
Posts: 20
Location/Company/Country: Red Vision, Manchester, UK

PostPosted: Fri May 01, 2009 9:00 am    Post subject: Reply with quote

I have put a few objects and a poly ground plane in a new maya 2009 scene. I added a ray-traced direction light and made the objects fully transparent. When I do a render I get the same issue with semitransparent shadows. Does anyone know how to fix this?
Back to top
View user's profile Send private message Visit poster's website

schoenberger
Site Admin


Joined: 02 Mar 2005
Posts: 3786

PostPosted: Fri May 01, 2009 8:19 pm    Post subject: Reply with quote

I was able to repro this Maya behavoir with a fresh scene, a plane and a sphere.
Again one of the new "auto-enabled-better-features" of Maya 2009.

I will try to find out where to disable this new shadow thing...
_________________
Holger Schönberger
Binary Alchemy - digital materialization
Back to top
View user's profile Send private message Send e-mail

schoenberger
Site Admin


Joined: 02 Mar 2005
Posts: 3786

PostPosted: Fri May 01, 2009 8:31 pm    Post subject: Reply with quote

Ok, I asked some Maya guys. They did also not find how to disable it in Maya 2009.
But we have found that it is somewhere in the lambert shader.
Just assign a "surface shader" instead. And make that transparent.
_________________
Holger Schönberger
Binary Alchemy - digital materialization
Back to top
View user's profile Send private message Send e-mail

grahamc



Joined: 27 Apr 2009
Posts: 20
Location/Company/Country: Red Vision, Manchester, UK

PostPosted: Sat May 02, 2009 12:48 pm    Post subject: Reply with quote

Great, the surface shader works a treat! No more BB shadows!

I have done some test renders, and I have found that the volume shader renders very fast and without any flickering.

Good work!

The fractal 4D is also really good. I have used afterburn in Max for years and have always wanted something similar in Maya. I have now found it!

Thanks for the help.

I will definitely be recommending that we purchase these shaders.

cheers

Laughing

Graham
Senior animator
Red Vision
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    www.BinaryAlchemy.de Forum Index -> Shader Problems / How do I...? All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
 
Documento sin título
 



Powered by phpBB © 2001, 2002 phpBB Group



Number of shameful bots caught by Anti-Spam ACP: 1667