www.BinaryAlchemy.de :: View topic - Adding different particle density shaders in one cloud.
 SearchSearch   RegisterRegister  ProfileProfile   UsergroupsUsergroups   Log inLog in 
If you create a new post, please use a topic that describes your problem
Documento sin título
 
Adding different particle density shaders in one cloud.

 
Post new topic   Reply to topic    www.BinaryAlchemy.de Forum Index -> Shader Bugs
View previous topic :: View next topic  
Author Message

danyargici



Joined: 17 Dec 2006
Posts: 25

PostPosted: Mon Apr 15, 2013 4:08 pm    Post subject: Adding different particle density shaders in one cloud. Reply with quote

I think I may have stumbled into a fairly significant bug with the volume shader that ships with Softimage (and I presume the latest BA_Volume).

If I filter different points using different Particle Density nodes and their 'Visible in Render' per point attributes and combine them again using the classic multi-math color_basic workflow (optimizations off etc. etc.) everything is fine.

However, when I turn on scattering I get an additive effect with each layer, even if it's completely empty and without points.

Is there any way around this?
Back to top
View user's profile Send private message Visit poster's website

schoenberger
Site Admin


Joined: 02 Mar 2005
Posts: 3785

PostPosted: Mon Apr 15, 2013 5:29 pm    Post subject: Reply with quote

Then there seems to be an issue with the particle density shader.
Try to place a clamp scalar node for the output density.

Otherwise I do not have a clue.
_________________
Holger Schönberger
Binary Alchemy - digital materialization
Back to top
View user's profile Send private message Send e-mail

danyargici



Joined: 17 Dec 2006
Posts: 25

PostPosted: Wed May 15, 2013 10:00 am    Post subject: Reply with quote

Hi Holger, would you mind if I contact you again via email, I am still having problems with shadow table artifacts in my render and would like to send you some references to get your opinion.

This is really really killing me now...
Back to top
View user's profile Send private message Visit poster's website

schoenberger
Site Admin


Joined: 02 Mar 2005
Posts: 3785

PostPosted: Wed May 15, 2013 12:15 pm    Post subject: Reply with quote

Please use
www.BinaryAlchemy.de/upload_b.php

But I cannot promise when I will have time. Really busy right now.
_________________
Holger Schönberger
Binary Alchemy - digital materialization
Back to top
View user's profile Send private message Send e-mail

danyargici



Joined: 17 Dec 2006
Posts: 25

PostPosted: Wed May 15, 2013 12:34 pm    Post subject: Reply with quote

Thanks, I have uploaded a rar file.

Inside are 3 quicktimes - the beauty and 2 AOVs (Illumination and Scatter). As you can see, the shadow table is visible and swimming on the hands and face (but not in the scattering). My minimum point size is 0.2 and the cell size was set at 0.15. I also included a png showing the grid as 0.15 for reference.

I'd be very grateful if you have a minute or two to take a look any offer any suggestions at all.

Many thanks again.

DAN
Back to top
View user's profile Send private message Visit poster's website

danyargici



Joined: 17 Dec 2006
Posts: 25

PostPosted: Thu May 16, 2013 8:28 am    Post subject: Reply with quote

Hi Holger, I don't suppose you have managed to find a moment to check the files I sent yesterday have you? I have now tried with Full Light raytrace mode (with adaptive raymarching set to 2 and light samples at 4) also and the problem is still present.

I suspect I may have found some bizarre corner case that the shader can't cope with.
Back to top
View user's profile Send private message Visit poster's website

schoenberger
Site Admin


Joined: 02 Mar 2005
Posts: 3785

PostPosted: Thu May 16, 2013 3:45 pm    Post subject: Reply with quote

It is very hard to see anything in the animation to know what is exactly the issue.
To check the shadow table, I would render in preview mode. There is a mode that renders the table.
(do not reduce the cells in preview mode)

Then I have seen that particles does die?
I would recommend to break the problem down. Otherwise you never find the issue:
* Remove all animation beside the movement. (noise shader, particle fade/death)

* Disable the ambient color in the volume shader and make the cloud completely white.
Render a sequence with one light only, full shadow darkness in the light. To check which light flickers.

* Reduce/Remove the noise shader via the slider in the particle shader.

* Then you use scatter? There is a scatter setting for the accurateness, the less the more flicker can occur.
Try to render without scatter. You can also set the scatter color to blue and compare one render in rgb for with and without scatter.

* Do you use AO?
The same, try to render without AO.
_________________
Holger Schönberger
Binary Alchemy - digital materialization
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic    www.BinaryAlchemy.de Forum Index -> Shader Bugs All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
 
Documento sin título
 



Powered by phpBB © 2001, 2002 phpBB Group



Number of shameful bots caught by Anti-Spam ACP: 1667