www.BinaryAlchemy.de :: View topic - Ba_RGB_Shadow problem with Arnold
 SearchSearch   RegisterRegister  ProfileProfile   UsergroupsUsergroups   Log inLog in 
If you create a new post, please use a topic that describes your problem
Documento sin título
 
Ba_RGB_Shadow problem with Arnold

 
Post new topic   Reply to topic    www.BinaryAlchemy.de Forum Index -> Shader Problems / How do I...?
View previous topic :: View next topic  
Author Message

ClumsyFingers



Joined: 19 Oct 2012
Posts: 4

PostPosted: Tue Oct 23, 2012 3:15 pm    Post subject: Ba_RGB_Shadow problem with Arnold Reply with quote

Hello,

I´ve been using Ba_RGB_Shadow shader to make a Shadow pass in Arnold, and I´ve had some problems.

I´ve found colour artifacts if I apply the sader to the whole partition, this artifacts only affects some lights, and sometimes dissapear if I use higher Shadow samples.



Other issues is the intensity, compairing the shadow pass with the original shadows, the shadow pass seems to be darker and with harder falloff. (1st img is the Shadow pass, 2nd is the original shadow)





The problem is that this images are not gamma corrected, and when I apply gamma correction, the shadow pass turns in this



instead of this



Maybe I´m not using the shader properly, or I´m not setting correctly Arnold so any help is apreciated.

Thanks
Back to top
View user's profile Send private message

schoenberger
Site Admin


Joined: 02 Mar 2005
Posts: 3786

PostPosted: Tue Oct 23, 2012 3:19 pm    Post subject: Reply with quote

Hi

I have to analyse the color error.

But the result should be right. Renders an image without shadow, an image with shadow and calculates the results. Perhaps it has issues with some types of lights. Special environment lights or similar.
If you have some repro scenes, please upload them via www.RoyalRender.de/upload.php
_________________
Holger Schönberger
Binary Alchemy - digital materialization
Back to top
View user's profile Send private message Send e-mail

ClumsyFingers



Joined: 19 Oct 2012
Posts: 4

PostPosted: Tue Oct 23, 2012 4:29 pm    Post subject: Reply with quote

Hi,

I´ve uploaded a scene called Huevo.scn

and I´ve gama corrected the shadow pass and the original shadow and composited them in difference mode. Maybe it helps... this is the result



I guess the white circle in the inner shadow should be black too.

Thanks again schoenberger for your incredible work.
Back to top
View user's profile Send private message

schoenberger
Site Admin


Joined: 02 Mar 2005
Posts: 3786

PostPosted: Tue Oct 23, 2012 4:32 pm    Post subject: Reply with quote

The shader does not work with any gamma.
So a difference of the gamma corrected images is not the same.
_________________
Holger Schönberger
Binary Alchemy - digital materialization
Back to top
View user's profile Send private message Send e-mail

ClumsyFingers



Joined: 19 Oct 2012
Posts: 4

PostPosted: Tue Oct 23, 2012 5:20 pm    Post subject: Reply with quote

Ok,

The result of the 2 images composited in difference mode without any gamma correction is this.



Notice the white ring around the inner part of the shadow.

Maybe the problem is in my workflow,

I have color management applied inside Softimage´s display preferences, but not in the render output.
I´m rendering in TIFF 16bit
The driver gamma and all the gamma inputs in Arnold are set to 1.

When I render all the passes y gamma correct each pass and then composite them.

Maybe I should composite the passes an then apply the gamma?
Back to top
View user's profile Send private message

schoenberger
Site Admin


Joined: 02 Mar 2005
Posts: 3786

PostPosted: Tue Oct 23, 2012 7:58 pm    Post subject: Reply with quote

The last image looks still wrong.
If would have to be ramp from light to dark and not light-dark-light.

As RGB_Shadow does not use any gamma, it works only with the images as they are rendered.
Not modified.
_________________
Holger Schönberger
Binary Alchemy - digital materialization
Back to top
View user's profile Send private message Send e-mail

ClumsyFingers



Joined: 19 Oct 2012
Posts: 4

PostPosted: Wed Oct 24, 2012 3:19 pm    Post subject: Reply with quote

Hi, I´ve been making tests with this scene and I noticed that the color artifacts only appear when arnold´s quad lights have a size greater than 4 in area light scaling parameter. Hope this helps
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    www.BinaryAlchemy.de Forum Index -> Shader Problems / How do I...? All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
 
Documento sin título
 



Powered by phpBB © 2001, 2002 phpBB Group



Number of shameful bots caught by Anti-Spam ACP: 1667