www.BinaryAlchemy.de :: View topic - Softimage 2011SP1 - Several Problems
 SearchSearch   RegisterRegister  ProfileProfile   UsergroupsUsergroups   Log inLog in 
If you create a new post, please use a topic that describes your problem
Documento sin título
 
Softimage 2011SP1 - Several Problems

 
Post new topic   Reply to topic    www.BinaryAlchemy.de Forum Index -> Shader Bugs
View previous topic :: View next topic  
Author Message

debris



Joined: 16 Apr 2007
Posts: 18

PostPosted: Mon Jun 21, 2010 2:42 pm    Post subject: Softimage 2011SP1 - Several Problems Reply with quote

Hi Holger!

Today we tried rendering our first job using Softimage 2011SP1 (x64 + x86 mixed renderfarm) with some BA-Shaders in them and found 2 annoying problems that weren't there in previous versions.

- BA_Color_Switcher's "switch" parameter is set to "1" with an override on a partition. This works fine in the viewport until we save an reload the scene again. Then the override is gone. I don't know whether it's a bug/feature in 2011's new shading system (they seem to have changed A LOT under the hood), or whether your BA_Shaders need to be compiled with the 2011 SDK or whatever.

- BA_Shaders don't work anymore on all of our 32bit machines. "Shader xxx not found". All the latest MSVC redistributables are installed and the same shaders rendered in 2010, 2010SP1 and AFAIK 2011. The x64 versions are rendering fine.

Best regards and thanks in advance
Steffen
Back to top
View user's profile Send private message

schoenberger
Site Admin


Joined: 02 Mar 2005
Posts: 3785

PostPosted: Mon Jun 21, 2010 5:07 pm    Post subject: Reply with quote

Hi

There will be a recompilation for the shader.
The shader require the Redist Package 2005 SP1.

The override issue seems to be a bug in XSI.
Until you render with Mental Ray, the shader DLL is not used.
Only the SPDL.
_________________
Holger Schönberger
Binary Alchemy - digital materialization
Back to top
View user's profile Send private message Send e-mail

debris



Joined: 16 Apr 2007
Posts: 18

PostPosted: Mon Jun 21, 2010 5:17 pm    Post subject: Reply with quote

Thanks Holger!

The redist package is installed (everything worked before) and the override problem really seems to be a Softimage bug.

Thanks for recompilation (any ETA for that? Otherwise I'll have to rebuild several shader networks to meet the deadline...)

Regards
Steffen
Back to top
View user's profile Send private message

schoenberger
Site Admin


Joined: 02 Mar 2005
Posts: 3785

PostPosted: Mon Jun 21, 2010 5:25 pm    Post subject: Reply with quote

I think the next shader update would be available middle of next month.
_________________
Holger Schönberger
Binary Alchemy - digital materialization
Back to top
View user's profile Send private message Send e-mail

debris



Joined: 16 Apr 2007
Posts: 18

PostPosted: Mon Jun 21, 2010 5:29 pm    Post subject: Reply with quote

OK, I'll rebuild it then Wink
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    www.BinaryAlchemy.de Forum Index -> Shader Bugs All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
 
Documento sin título
 



Powered by phpBB © 2001, 2002 phpBB Group



Number of shameful bots caught by Anti-Spam ACP: 1667