www.BinaryAlchemy.de :: View topic - Deformation on a Geometry Mesh
 SearchSearch   RegisterRegister  ProfileProfile   UsergroupsUsergroups   Log inLog in 
If you create a new post, please use a topic that describes your problem
Documento sin título
 
Deformation on a Geometry Mesh

 
Post new topic   Reply to topic    www.BinaryAlchemy.de Forum Index -> Shader Problems / How do I...?
View previous topic :: View next topic  
Author Message

WilliamP



Joined: 22 Oct 2007
Posts: 11
Location/Company/Country: Digimata, Toronto, Canada

PostPosted: Fri Aug 21, 2009 10:22 pm    Post subject: Deformation on a Geometry Mesh Reply with quote

Hello

I have a Geometry Mesh driven by Particle Density from an ICE Particle Cloud, and it is forming surfaces just fine, and all the textures are coming through on the resulting mesh, EXCEPT the Deformation.

I keep getting a 'clipped to maximum displacement 0' message. As both the GeoShader that the Geometry Mesh is attached to, as well as the default scene Geometry Approximation have Displacements set at 2, I'm wondering why it isn't giving me anything.

Any suggestions? I'm in XSI 7.01 and still using Volume_v3.6.20

Thanks!

William
Back to top
View user's profile Send private message

schoenberger
Site Admin


Joined: 02 Mar 2005
Posts: 3786

PostPosted: Fri Aug 21, 2009 10:33 pm    Post subject: Reply with quote

I have checked it.
The max displace setting has to be set in the geo shader itself.
And it is currently not set.
I will add a bug report to set it to 2.0
_________________
Holger Schönberger
Binary Alchemy - digital materialization
Back to top
View user's profile Send private message Send e-mail

WilliamP



Joined: 22 Oct 2007
Posts: 11
Location/Company/Country: Digimata, Toronto, Canada

PostPosted: Fri Aug 21, 2009 11:46 pm    Post subject: Reply with quote

This is an issue with XSI then and not your shader? And I'm presuming that if this is XSI's problem there is no hope of a fix for quite some time...

What I'm worried about is that this is part of some testing that I am doing for a job that will need to be in serious development within a few weeks, so is the issue likely to be resolved in that time frame or should I be going down some other road?
Back to top
View user's profile Send private message

schoenberger
Site Admin


Joined: 02 Mar 2005
Posts: 3786

PostPosted: Sat Aug 22, 2009 12:26 pm    Post subject: Reply with quote

It is an issue in the shader.

And with XSI you would be right, as they just have finished 2010.
But 2010 has a volume shader memory>4GB fix implemented, which I reported last month.
So they still fix stuff.

I will do some shader updates mid/end of september.
_________________
Holger Schönberger
Binary Alchemy - digital materialization
Back to top
View user's profile Send private message Send e-mail

WilliamP



Joined: 22 Oct 2007
Posts: 11
Location/Company/Country: Digimata, Toronto, Canada

PostPosted: Sat Aug 22, 2009 10:47 pm    Post subject: Reply with quote

Thanks...

I guess I'll keep moving forward with the shader as it is and just add the deformation into the scene later when it arrives.

W
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    www.BinaryAlchemy.de Forum Index -> Shader Problems / How do I...? All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
 
Documento sin título
 



Powered by phpBB © 2001, 2002 phpBB Group



Number of shameful bots caught by Anti-Spam ACP: 1667