www.BinaryAlchemy.de :: View topic - Problems after upgrading XSI
 SearchSearch   RegisterRegister  ProfileProfile   UsergroupsUsergroups   Log inLog in 
If you create a new post, please use a topic that describes your problem
Documento sin título
 
Problems after upgrading XSI

 
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    www.BinaryAlchemy.de Forum Index -> old - RR Questions - v6.x
View previous topic :: View next topic  
Author Message

jean-louis



Joined: 25 Feb 2008
Posts: 63
Location/Company/Country: Digital Golem

PostPosted: Wed May 07, 2014 1:06 pm    Post subject: Problems after upgrading XSI Reply with quote

Hi,

So god knows why we have these persistent problems, but basically we have upgraded to xsi 2014 SP2 (from 2012) and the appropriate SItoA 3.0.2 and to be sure we created a fresh workgroup specially for 2014 with *only* SItoA in it for now.

Arnold renders are failing, while mental ray ones seem fine.
Here is a log dump from a render box (linux):
Code:

=============================
 Autodesk Softimage 12.1.99.0
=======================================================

rrErr: Initialize Mental Ray: Elapsed time (ms): 50.56

rrErr: Load Command Definitions: Elapsed time (ms): 34.94
rrErr: Project List Initialization: Elapsed time (ms): 18.28

14716: old priority 0, new priority 15
E  0| ++++++++++++++++++++++++ Log Start +++++++++++++++++++++++++
E  1| Rdroid1  rrClient console     7.0.01    rrVer7.0.01+7.02.41
E  2| 05.07 13:27.35
E  3| Client is running on Fedora 11(redhat) x64 8x2.7 GenuineIntel 21.3Ghz
E  4| Job: {13H}  Sequence: 5-20, 5
E  5| Scene: .../    RHEA_0010_3DXSI/    Test_Scene_JL_002_lx 536.00Kb 05.07 13:56.17
E  6| Render config used: Softimage Arnold Render   3D01__Softimage__Arnold_2011.cfg
E  7| Executable used: /usr/Softimage/Softimage_2014_SP2/.xsi_2014_SP2   
E  8| rrExeBit x64
E  9| rrExeVersion 2014.2
E 10| rrExeVersionMinReq 2014.2
E 11| rrExeVersionMajor 2014
E 12| rrExeVersionMinor 2
E 13| rrExeOS lx
E 14| ++++++++++++ Environment Variables Job: ++++++++++++++++++++
E 15| rrJobRenderapp Softimage
E 16| rrJobRenderer Arnold Render
E 17| rrJobProject RHEA
E 18| rrJobType 3D
E 19| rrJobRenderType
E 20| rrJobBit x64
E 21| rrJobVersion 2014.1
E 22| rrJobVersionMajor 2014
E 23| rrJobVersionMinor 1
E 24| rrJobTiled false
E 25| rrJobCustomScene t
E 26| rrJobCustomShot
E 27| rrJobCustomVersion
E 28| rrJobSceneOS win
E 29| ++++++++++++ Environment Variables Client: +++++++++++++++++
E 30| rrClientName Rdroid1
E 31| rrClientCores 8
E 32| rrClientCoresUsed 6
E 33| rrClientBit x64
E 34| rrClientRenderInstance 0
E 35| RR_ROOT /RR
E 36| rrBin /RR/bin/lx64/
E 37| rrPlugins /RR/render_apps/renderer_plugins/softimage/lx_x64/
E 38| rrPluginsNoOS /RR/render_apps/renderer_plugins/softimage/
E 39| rrPrefs /RR/render_apps/renderer_prefs/softimage/lx_x64/
E 40| rrSharedExeDir /RR/render_apps/renderer_exe/softimage/lx_x64/
E 41| rrLocalTemp /usr/local/RR_localdata/temp/A/
E 42| TEMP /usr/local/RR_localdata/temp/A
E 43| TMP /usr/local/RR_localdata/temp/A
E 44| rrLocalRoot /usr/local/RR_localdata/
E 45| rrLocalExeDir /usr/local/RR_localdata/renderer_exe/softimage/lx_x64/
E 46| rrLocalPrefs /usr/local/RR_localdata/renderer_prefs/softimage/lx_x64/
E 47| rrLocalPlugins /usr/local/RR_localdata/renderer_plugins/softimage/lx_x64/
E 48| rrBaseAppPath /usr/Softimage/Softimage_2014_SP2
S  0| ++++++++++++ Environment Variables Done  +++++++++++++++++++
S  1| source \"/usr/local/RR_localdata/_global.sh\"
S  2| we are logged in as:
S  3| uid=501(rruser) gid=501(rruser)
S  4| USER is set to rruser
S  5| home is not set
S  6| HOME is set to /home/rruser
S  7| source \"/usr/Softimage/Softimage_2014_SP2/.xsi_2014_SP2\"
S  8| source \"/usr/local/RR_localdata/softimage.sh\"
S  9| WorkgroupPath is set to /XSI/WORKGROUP2014
S 10| /RR/bin/lx64/rrCopy -oa /RR/render_apps/renderer_prefs/softimage/lx_x64/default.xsipref \"${XSI_USERHOME}\Data\Preferences\default.xsipref\"
S 11| . ----------------------------------------------------------------
S 12| . rrCopy  7.0.b4+6.2
S 13| . Copyright(c)  Holger Schoenberger. All rights reserved.
S 14|     Binary Alchemy - digital materialization
S 15| . ----------------------------------------------------------------
S 16| . Source file '' does not exist!
S 17| /RR/bin/lx64/rrFilereplace \"${XSI_USERHOME}\Data\Preferences\default.xsipref\" \"**ReplaceWorkgroup**;;${WorkgroupPath}\"
S 18| ----------------------------------------------------------------
S 19| rrFilereplace  7.0.b2+6.2      Copyright(c)  Holger Schoenberger. All rights reserved.
S 20|
S 21| ----------------------------------------------------------------
S 22| Error: input file does not exist! '/usr/local/RR_localdata/renderer_prefs/softimage/lx_x64/2014.2\Data\Preferences\default.xsipref'
S 23|
R  0| \"/RR/bin/lx64/rrResetexitcode\"
R  1| +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
R  2| ++++++++++++++++++++++++++++++++++++++++++ START ++++++++++++++++++++++++++++++++++++++++++++++
R  3| ++++++++++++++++++++++++++++++++++++++++ 7.0.b4+6.2 ++++++++++++++++++++++++++++++++++++++++++
R  4| +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
R  5| \"/usr/Softimage/Softimage_2014_SP2/Application/bin/XSIBATCH.bin\" -processing -thread 6 -script \"/RR/render_apps/scripts/kso_softimage.py\" -lang Python -main rrStart -args -argAll \" PyModPath: /RR/render_apps/scripts, SName: /PROJECTS/RHEA/SHOTS/vfx_0010/RHEA_0010_3DXSI/Scenes/Test_Scene_JL_002_lx.scn, Db: /PROJECTS/RHEA/SHOTS/vfx_0010/RHEA_0010_3DXSI, Pass: Default_Pass,  SkipFrame: false , FName: /usr/local/RR_localdata/renderout/A/SHOTS/vfx_0010/RHEA_0010_3DXSI/Render_Pictures/<Layer>_Main. , FExt: .tif , FrStart: 5, FrEnd: 20, FrStep: 5 , FrOffset: 0 ,   Verbose: 0,    \"
R  6| ==========================rrErr: Scan for Custom SPDLs: Elapsed time (ms): 42.83
R  7| rrErr: Loading User plug-ins: Elapsed time (ms): 0.19
R  8| rrErr: Loading User addon plug-ins: Elapsed time (ms): 0.10
R  9| rrErr: Loading Workgroup plug-ins: Elapsed time (ms): 0.00
R 10| rrErr: Loading Workgroup addon plug-ins: Elapsed time (ms): 0.00
R 11|
R 12| License information: using [Processing]
R 13| rrErr: Loading Factory plug-ins: Elapsed time (ms): 787.65
R 14|
R 15| rrErr: Loading Factory addon plug-ins: Elapsed time (ms): 1993.33
R 16| rrErr: Loading setup plug-ins: Elapsed time (ms): 0.02
R 17| rrErr: XSI Init: Elapsed time (s): 7.56
R 18|
R 19| COMMAND: -processing -thread 6 -script /RR/render_apps/scripts/kso_softimage.py -lang Python -main rrStart -args -argAll " PyModPath: /RR/render_apps/scripts, SName: /PROJECTS/RHEA/SHOTS/vfx_0010/RHEA_0010_3DXSI/Scenes/Test_Scene_JL_002_lx.scn, Db: /PROJECTS/RHEA/SHOTS/vfx_0010/RHEA_0010_3DXSI, Pass: Default_Pass,  SkipFrame: false , FName: /usr/local/RR_localdata/renderout/A/SHOTS/vfx_0010/RHEA_0010_3DXSI/Render_Pictures/<Layer>_Main. , FExt: .tif , FrStart: 5, FrEnd: 20, FrStep: 5 , FrOffset: 0 ,   Verbose: 0,    "
R 20| ' INFO : ' 13:27.45 rrSI      :
R 21| ' INFO : ' 13:27.45 rrSI      : Flag  sname          : '/PROJECTS/RHEA/SHOTS/vfx_0010/RHEA_0010_3DXSI/Scenes/Test_Scene_JL_002_lx.scn'
R 22| ' INFO : ' 13:27.45 rrSI      : Flag  db             : '/PROJECTS/RHEA/SHOTS/vfx_0010/RHEA_0010_3DXSI'
R 23| ' INFO : ' 13:27.45 rrSI      : Flag  pass           : 'Default_Pass'
R 24| ' INFO : ' 13:27.45 rrSI      : Flag  skipframe      : 'False'
R 25| ' INFO : ' 13:27.45 rrSI      : Flag  fname          : '/usr/local/RR_localdata/renderout/A/SHOTS/vfx_0010/RHEA_0010_3DXSI/Render_Pictures/<Layer>_Main.'
R 26| ' INFO : ' 13:27.45 rrSI      : Flag  fext           : '.tif'
R 27| ' INFO : ' 13:27.45 rrSI      : Flag  frstart        : '5'
R 28| ' INFO : ' 13:27.45 rrSI      : Flag  frend          : '20'
R 29| ' INFO : ' 13:27.45 rrSI      : Flag  frstep         : '5'
R 30| ' INFO : ' 13:27.45 rrSI      : Flag  froffset       : '0'
R 31| ' INFO : ' 13:27.45 rrSI      : Flag  verbose        : '0'
R 32| ' INFO : ' 13:27.45 rrSI      : Flag  pymodpath      : '/RR/render_apps/scripts'
R 33| ' INFO : ' 13:27.45 rrSI      : Active Shader Workgroup:
R 34| ' INFO : ' 13:27.45 rrSI      : Set project to '/PROJECTS/RHEA/SHOTS/vfx_0010/RHEA_0010_3DXSI'...
R 35| ' INFO : ' 13:27.46 rrSI      : Active Project: /PROJECTS/RHEA/SHOTS/vfx_0010/RHEA_0010_3DXSI
R 36| ' INFO : ' 13:27.46 rrSI      : Loading Scene '/PROJECTS/RHEA/SHOTS/vfx_0010/RHEA_0010_3DXSI/Scenes/Test_Scene_JL_002_lx.scn'...
R 37| >Loading: /PROJECTS/RHEA/SHOTS/vfx_0010/RHEA_0010_3DXSI/Scenes/Test_Scene_JL_002_lx.scn...
R 38| ' INFO : 4034 - Loaded scene was created with build number: 12.1.99.0 - compatibility version: 1200
R 39| ' ERROR : 2356 - This plug-in is not installed: Arnold Render Options
R 40| ' ERROR : 2000 - 'Arnold Render' is not a valid render engine.
R 41| OpenScene "/PROJECTS/RHEA/SHOTS/vfx_0010/RHEA_0010_3DXSI/Scenes/Test_Scene_JL_002_lx.scn", False
R 42| ' INFO : ' 13:27.46 rrSI      : Set project to '/PROJECTS/RHEA/SHOTS/vfx_0010/RHEA_0010_3DXSI'...
R 43| ' INFO : ' 13:27.46 rrSI      : Active Project: /PROJECTS/RHEA/SHOTS/vfx_0010/RHEA_0010_3DXSI
R 44| ' INFO : ' 13:27.46 rrSI      : Set pass to 'Default_Pass'
R 45| SetCurrentPass "Passes.Default_Pass"
R 46| ' INFO : ' 13:27.46 rrSI      : renderer used: 'Mental Ray'
R 47| ' INFO : ' 13:27.46 rrSI      : Set FrameSkipRendered to False
R 48| SetValue "Passes.Default_Pass.FrameSkipRendered", False
R 49| SetValue "Passes.Default_Pass.Main.Enabled", True
R 50| ' INFO : ' 13:27.46 rrSI      : Set Filename to /usr/local/RR_localdata/renderout/A/SHOTS/vfx_0010/RHEA_0010_3DXSI/Render_Pictures/[Pass]_Main.[Frame ].tif
R 51| SetValue "Passes.Default_Pass.Main.Filename", "/usr/local/RR_localdata/renderout/A/SHOTS/vfx_0010/RHEA_0010_3DXSI/Render_Pictures/[Pass]_Main.[Frame ].tif"
R 52| SetValue "Passes.Default_Pass.mentalray.VerbosityLevel", "0"
R 53| ' INFO : ' 13:27.46 rrSI      : Changing current frame to 5
R 54| SetValue "PlayControl.Current", 5
R 55| SceneRefresh
R 56| ' INFO : ' 13:27.46 rrSI      : Scene init done, starting to render...
R 57| ' INFO : ' 13:27.46 rrSI      : Scene load time: 0:00:00.310620  h:m:s.ms
R 58| ' ERROR : 21000-REND-RenderPass - Unspecified failure
R 59| RenderPass "Passes.Default_Pass", , 5, 20, 5
R 60| Command failed, returned -2147467259
R 61| ' ERROR : Traceback (most recent call last):
R 62| ' File "
R 63| '     render_default(arg)
R 64| ' File "
R 65| '     xsi.renderpass (arg.Pass ,"",  arg.FrStart,arg.FrEnd,arg.FrStep)
R 66| '   File "<COMObject>", line 2, in renderpass
R 67| ' COM Error: Unspecified error
R 68| '  (0x-7fffbffb) - [line 156]
R 69| ERROR - Script failed.
R 70| FATAL - Script Aborted.
R 71|
R 72| ' INFO : Rendering pass 'Default_Pass'...
R 73| ' INFO : Rendering frame 5 (0.0% done)
R 74| ' INFO : Characters has been unloaded.
R 75| ' INFO : TransformUVsPlugin has been unloaded.
R 76| ' INFO : Unfold3D Plugin has been unloaded.
R 77| ' INFO : FBX-XSI import/export Plug-in has been unloaded.
R 78| ' INFO : polymatricksPlugin has been unloaded.
R 79|
R 80| +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
R 81| +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
R 82| ++++++++++++++++++++++++++++++++++++ Render Executable done +++++++++++++++++++++++++++++++++++
R 83| ++++++++++++++++++++ Royal Render checks the return code of the executable ++++++++++++++++++++
R 84| ++++++++++++++++++++++++++++++++++++++ 05.07. 13:27.49 +++++++++++++++++++++++++++++++++++++
R 85| ++++ Executable returned 1 (0x 1) as exit code for frame 5.
R 86| +++++ Executable crashed
R 87| -
R 88| +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
R 89| ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
   0| Rdroid1  rrClient console     7.0.01    rrVer7.0.01+7.02.41
   1| Job ID: {13H}
   2| ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
   3|


Permissions are all set to read write [execute] for all.
I don't understand why it says it can't find arnold render options since that is in the workgroup.
Things render fine on local machines (windows & linux)

Should we do a completely fresh install of RR?

Please help - every single time we update we are going through these problems and we lose a lot of time.

EDIT: here's the last bit of the log:

Code:
C  0| ************************* LOCAL RENDER INFORMATION *************************
C  1| Total render files found:     0
C  2| Files successful copied:      0
C  3| Files broken/not copied:      0
C  4| Total render files found (main pass only):     0
C  5| List of files: (C=copied    R=successfully read    X=Exr cropped    F=image verify failed    V=rrViewer cache created)
C  6| ************************* CLIENT REPORTS DURING THIS RENDER *************************
C  7|
C  8| Error in log file: error: input file does not exist! '/usr/local/rr_localdata/renderer_prefs/softimage/lx_x64/2014.2\data\preferences\default.xsipref'
C  9|
C 10| Error in log file: error: input file does not exist! '/usr/local/rr_localdata/renderer_prefs/softimage/lx_x64/2014.2\data\preferences\default.xsipref'
C 11|
C 12| Error in log file: ' error : 2356 - this plug-in is not installed: arnold render options
C 13|
C 14| Error in log file: ' error : 2356 - this plug-in is not installed: arnold render options
C 15|
C 16| Error in log file: ' error : 2000 - 'arnold render' is not a valid render engine.
C 17|
C 18| Error in log file: ' error : 2000 - 'arnold render' is not a valid render engine.
C 19|
C 20| Error in log file: ' error : 21000-rend-renderpass - unspecified failure
C 21|
C 22| Error in log file: ' error : 21000-rend-renderpass - unspecified failure
C 23|
C 24| Error in log file: ' error : traceback (most recent call last):
C 25|
C 26| Error in log file: ' error : traceback (most recent call last):
C 27|
C 28| Error in log file: ' com error: unspecified error
C 29|
C 30| Error in log file: ' com error: unspecified error
C 31|
C 32| Error in log file: error - script failed.
C 33|
C 34| Error in log file: error - script failed.
C 35|
C 36|
C 37| Job crashed
C 38|
C 39|


Thanks,
Jean-Louis
Back to top
View user's profile Send private message

schoenberger
Site Admin


Joined: 02 Mar 2005
Posts: 3785

PostPosted: Wed May 07, 2014 1:26 pm    Post subject: Reply with quote

Hi

For RR 7.0 we changed the way workgroups work and the render script.

There is a file missing
/RR/render_apps/renderer_prefs/softimage/lx_x64/default.xsipref
Please get that file from the latest installer. You cna just extract the installer and copy the file from the subfolder.
It is required to set the workgroup for Softimage.
_________________
Holger Schönberger
Binary Alchemy - digital materialization
Back to top
View user's profile Send private message Send e-mail

jean-louis



Joined: 25 Feb 2008
Posts: 63
Location/Company/Country: Digital Golem

PostPosted: Wed May 07, 2014 1:40 pm    Post subject: Reply with quote

Thanks Holger, but actually that file exists already and contains the same line as the one I downloaded from the installer:

data_management.workgroup_appl_path = **ReplaceWorkgroup**

And the permissions on the file are 777 so I'm afraid that's almost certainly not the problem!
Do you agree?

Jean-Louis
Back to top
View user's profile Send private message

schoenberger
Site Admin


Joined: 02 Mar 2005
Posts: 3785

PostPosted: Wed May 07, 2014 2:08 pm    Post subject: Reply with quote

Ok, then it has to be a copy issue.
Please extract and copy the file www.RoyalRender.de/download/rrCopy.zip to RR/bin/lx64/


The whole problem is the error message after
S 10| /RR/bin/lx64/rrCopy -oa /RR/render_apps/renderer_prefs/softimage/lx_x64/default.xsipref \"${XSI_USERHOME}\Data\Preferences\default.xsipref\"



Note: The whole Softimage render scripts have now all features and will not be changed any more with the next updates. (As there will not be any more changes to SI)
_________________
Holger Schönberger
Binary Alchemy - digital materialization
Back to top
View user's profile Send private message Send e-mail

jean-louis



Joined: 25 Feb 2008
Posts: 63
Location/Company/Country: Digital Golem

PostPosted: Wed May 07, 2014 2:30 pm    Post subject: Reply with quote

Hi Holger,

Thanks for sending that file. Unfortunately it hasn't solved the problem.

For comparison, we also have some 2012 renders going on, with the appropriate SItoA version installed in another workgroup (named WORKGROUP64)

Here is a snippet of the log file when things are fine:

Code:
S  0| ++++++++++++ Environment Variables Done  +++++++++++++++++++
S  1| source \"/usr/local/RR_localdata/_global.sh\"
S  2| we are logged in as:
S  3| uid=501(rruser) gid=501(rruser) context=system_u:system_r:initrc_t:s0
S  4| USER is set to rruser
S  5| home is not set
S  6| HOME is set to /home/rruser
S  7| source \"/usr/Softimage/Softimage_2012/.xsi_2012\"
S  8| source \"/usr/local/RR_localdata/softimage.sh\"
S  9| WorkgroupPath is set to /XSI/WORKGROUP64
S 10| /RR/bin/lx64/rrCopy -oa /RR/render_apps/renderer_prefs/softimage/lx_x64/default.xsipref \"${XSI_USERHOME}\Data\Preferences\default.xsipref\"
S 11| . ----------------------------------------------------------------
S 12| . rrCopy  7.0.02+6.02.42
S 13| . Copyright(c)  Holger Schoenberger. All rights reserved.
S 14|     Binary Alchemy - digital materialization
S 15| . ----------------------------------------------------------------
S 16| . Source file '' does not exist!
S 17| /RR/bin/lx64/rrFilereplace \"${XSI_USERHOME}\Data\Preferences\default.xsipref\" \"**ReplaceWorkgroup**;;${WorkgroupPath}\"
S 18| ----------------------------------------------------------------
S 19| rrFilereplace  7.0.b2+6.2      Copyright(c)  Holger Schoenberger. All rights reserved.
S 20|
S 21| ----------------------------------------------------------------
S 22| Error: input file does not exist! '/usr/local/RR_localdata/renderer_prefs/softimage/lx_x64/2012.0\Data\Preferences\default.xsipref'
S 23|
R  0| \"/RR/bin/lx64/rrResetexitcode\"


As you can see it still says it can't find the xsipref file, yet it finds the workgroup and renders fine.

Do you think it would be worth doing a fresh install of RR or is that not going to solve anything?

Jean-Louis
Back to top
View user's profile Send private message

schoenberger
Site Admin


Joined: 02 Mar 2005
Posts: 3785

PostPosted: Wed May 07, 2014 2:36 pm    Post subject: Reply with quote

A fresh install will not help.

The workgroup is set as environment variable, but not applied to the XSI preferences.
As the preference file cannot be copied somehow.

Do you have a teamviewer running on one of the clients? So I can check myself?
_________________
Holger Schönberger
Binary Alchemy - digital materialization
Back to top
View user's profile Send private message Send e-mail

jean-louis



Joined: 25 Feb 2008
Posts: 63
Location/Company/Country: Digital Golem

PostPosted: Wed May 07, 2014 2:41 pm    Post subject: Reply with quote

OK - the clients run in command line only, but I can lift one to init 5 and install teamviewer. Give me 5 mins...

JL
Back to top
View user's profile Send private message

schoenberger
Site Admin


Joined: 02 Mar 2005
Posts: 3785

PostPosted: Wed May 07, 2014 2:45 pm    Post subject: Reply with quote

Or we can do a session to a windows/osx machine and use putty to get into a terminal.

Windows:
http://www.RoyalRender.de/download/TeamViewer_RR.exe
OSX:
http://www.RoyalRender.de/download/TeamViewer_RR_OSX.zip
_________________
Holger Schönberger
Binary Alchemy - digital materialization
Back to top
View user's profile Send private message Send e-mail

jean-louis



Joined: 25 Feb 2008
Posts: 63
Location/Company/Country: Digital Golem

PostPosted: Wed May 07, 2014 2:55 pm    Post subject: Reply with quote

OK - ID: 261 968 464

You've got (on screen 1):

- rrControl running
- Putty logged into rdroid2
- the RR folder open
Back to top
View user's profile Send private message
Display posts from previous:   
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    www.BinaryAlchemy.de Forum Index -> old - RR Questions - v6.x All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
 
Documento sin título
 



Powered by phpBB © 2001, 2002 phpBB Group



Number of shameful bots caught by Anti-Spam ACP: 1667