www.BinaryAlchemy.de :: View topic - Testing RR (SI + Arnold) - some problems/questions ahead...
 SearchSearch   RegisterRegister  ProfileProfile   UsergroupsUsergroups   Log inLog in 
If you create a new post, please use a topic that describes your problem
Documento sin título
 
Testing RR (SI + Arnold) - some problems/questions ahead...

 
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    www.BinaryAlchemy.de Forum Index -> old - RR Questions - v6.x
View previous topic :: View next topic  
Author Message

robw



Joined: 14 Sep 2007
Posts: 15
Location/Company/Country: Amsterdam

PostPosted: Fri Jan 17, 2014 3:18 pm    Post subject: Testing RR (SI + Arnold) - some problems/questions ahead... Reply with quote

Hi,

I installed the latest RR for testing, followed the install/setup instructions, but am running into some issues regarding file access.
Installation and such ran fine, and I can start up client/submitter etc. with no issues.

Test setup is as follows:
- a fileserver: runs RR, Softimage license server and contains Arnold workgroup, scenes and files.
- a workstation: runs Arnold (+ license server) + Softimage.

on the fileserver, RR server console is running. In SI I created an .ass sequence for testing.
on the workstation I closed SI, started the client and the submitter so I can can send out the sequence for rendering.

The first part goes well, but than the client cannot see the .ass sequence. The folders etc. for the rendered sequence are created on the server.

log from client:
01.17 15:16.49| {36U} Job Received: {36U} RowuMedia|Softimage|--| \ Default_Pass_Main.<FN3>
01.17 15:16.49| {36U} Rendering Job 1-1,10
01.17 15:16.49| {36U} Rendering to: C:\RR_localdata\renderout\A\Render_Pictures\vanduin_anim_modellen_Los\Default_Pass\Main\Default_Pass_Main.
01.17 15:16.49| ERR - {36U} Scene \\RWSERVER\Projects\RowuMedia\3D\XSI\vanduin\Arnold_Scenes\Default_Pass_Main.<FN3>.ass not found.;; (p:_cJobThread::startNewJob) rrClient L 7.0.b8q+6.2 [439dcd,0,,,|5419c321,,,,|5b702fbd,,,,145|]
01.17 15:16.50| connecting...
01.17 15:16.50| connection established
01.17 15:16.50| Sending client status '{36U} Render Crashed'
01.17 15:16.50| Server connection took 0.010s
01.17 15:16.50| Disconnected (socket buffer size 0.00 MB)

I checked out the forum, but getting lost in tons of config files, scripts and things. :-\

Question: What is the local RR_data doing? Why is RR trying to render to the C:\ drive, and copy the kick.exe?

sorry if this has been discussed before, but having a hard time to understand what 'goes where'....

rob
Back to top
View user's profile Send private message

schoenberger
Site Admin


Joined: 02 Mar 2005
Posts: 3786

PostPosted: Fri Jan 17, 2014 3:27 pm    Post subject: Reply with quote

>What is the local RR_data doing? Why is RR trying to render to the C:\ drive
That is the "local render out" enabled at the job.
www.RoyalRender.de/help/index.htm?Infos/Local_Data_Fold/Local_Data_Folder.htm

>copy the kick.exe?
Arnold Standalone is setup as shared executable:
www.RoyalRender.de/help/index.htm?Renderer/Archive__sl__St/Arnold/Setup/Setup.htm


>but than the client cannot see the .ass sequence.
Just to recheck: Does the file
\\RWSERVER\Projects\RowuMedia\3D\XSI\vanduin\Arnold_Scenes\Default_Pass_Main.001.ass
exists and there is no difference in the file name?


Which user is running the client?
Please login with that user and try to access the file.
_________________
Holger Schönberger
Binary Alchemy - digital materialization
Back to top
View user's profile Send private message Send e-mail

robw



Joined: 14 Sep 2007
Posts: 15
Location/Company/Country: Amsterdam

PostPosted: Fri Jan 17, 2014 3:55 pm    Post subject: Reply with quote

Hi Holger,

Thanks for the quick answer. Much appreciated.

Ok, so I copied the Arnold bin over and changed the batfile, according to the 'standalone' helpfile.

And I checked the client login, and that's the same user with full access to the server and files.

Trying to resend the sequence for rendering, I get the same cannot find file error as before:

01.17 15:40.47| {30R} Job Received: {30R} RowuMedia|Softimage|--| \ Default_Pass_Main.<FN3>
01.17 15:40.48| {30R} Rendering Job 1-1,10
01.17 15:40.48| {30R} Rendering to: C:\RR_localdata\renderout\A\Render_Pictures\vanduin_anim_modellen_Los\Default_Pass\Main\Default_Pass_Main.
01.17 15:40.48| ERR - {30R} Scene \\RWSERVER\Projects\RowuMedia\3D\XSI\vanduin\Arnold_Scenes\Default_Pass_Main.<FN3>.ass not found.;; (p:_cJobThread::startNewJob) rrClient L 7.0.b8q+6.2 [439dcd,0,,,|5419c321,,,,|5b702fbd,,,,145|]
01.17 15:40.49| connecting...
01.17 15:40.49| connection established
01.17 15:40.49| Sending client status '{30R} Render Crashed'
01.17 15:40.49| Server connection took 0.012s
01.17 15:40.49| Disconnected (socket buffer size 0.00 MB)

In the client you can see the CPU spiking for a moment, but than the renderer crashed error pops up.
Back to top
View user's profile Send private message

robw



Joined: 14 Sep 2007
Posts: 15
Location/Company/Country: Amsterdam

PostPosted: Fri Jan 17, 2014 4:12 pm    Post subject: Reply with quote

Hi Holger,

after restarting the client, now I get this:

01.17 16:10.36| ERR - Unable to load stat file '\\Rwserver\Apps\RoyalRender\sub\stats\I7-PC.stdb' Wrong Magic ID;; (_rrClientStats::Load) rrClient L 7.0.b8q+6.2 [541dcdc2,,,,|5448aacf,,,,|5419c321,,,,|]
01.17 16:10.36| Clear all local render out folder 'C:\RR_localdata\renderout\'...
01.17 16:10.36| Clear all local temp folder 'C:\RR_localdata\temp\'...
01.17 16:10.38| List Processes (minCore=15% ( 1.2% total))

01.17 16:10.38| User logged in: rob
01.17 16:10.38| User login change: 'rob'
01.17 16:10.38| DailyExecute: Clearing...C:\RR_localdata\temp\ (files older than 01.17 10:10.3Cool
01.17 16:10.38| DailyExecute: Clearing...C:\RR_localdata\cachedscenes\
01.17 16:10.38| DailyExecute: LocalTextureFreeDriveSpace...
01.17 16:10.38| DailyExecute: delete .txt logs in C:\RR_localdata\...
01.17 16:10.58| Sending client status 'Idle'
Back to top
View user's profile Send private message

schoenberger
Site Admin


Joined: 02 Mar 2005
Posts: 3786

PostPosted: Fri Jan 17, 2014 4:19 pm    Post subject: Reply with quote

Please check the job in rrControl, tab "job info.
What is displayed as "Render App:"
_________________
Holger Schönberger
Binary Alchemy - digital materialization
Back to top
View user's profile Send private message Send e-mail

robw



Joined: 14 Sep 2007
Posts: 15
Location/Company/Country: Amsterdam

PostPosted: Fri Jan 17, 2014 4:33 pm    Post subject: Reply with quote

Hi Holger,

it states Softimage Arnold Render 2013.1 (3d) [;Arnold Render]

rob
Back to top
View user's profile Send private message

schoenberger
Site Admin


Joined: 02 Mar 2005
Posts: 3786

PostPosted: Fri Jan 17, 2014 4:37 pm    Post subject: Reply with quote

That is wrong.
You are not rendering with Softimage. Have you changed anything in the submitter?

Just load .ass file and submit it:
www.RoyalRender.de/help/index.htm?Renderer/Archive__sl__St/Arnold/Submission/Submission.htm
_________________
Holger Schönberger
Binary Alchemy - digital materialization
Back to top
View user's profile Send private message Send e-mail

robw



Joined: 14 Sep 2007
Posts: 15
Location/Company/Country: Amsterdam

PostPosted: Fri Jan 17, 2014 4:53 pm    Post subject: Reply with quote

ok, tried that, now i'm getting this:

01.17 16:43.17| {4JRa} Job Received: {4JRa} RowuMedia|Arnold|--|es \ Default_Pass_Main.<FN3>
01.17 16:43.17| {4JRa} Rendering Job 50-57,1
01.17 16:43.17| {4JRa} Rendering to: C:\RR_localdata\renderout\A\Render_Pictures\vanduin_anim_modellen_Los\Default_Pass\Main\Default_Pass_Main.
01.17 16:43.17| {4JRa} Executable copy: start sync... '\\Rwserver\Apps\RoyalRender\render_apps\renderer_exe\arnold\win_x64\' => 'C:\RR_localdata\renderer_exe\arnold\win_x64\'
01.17 16:43.18| {4JRa} Executable copy: 0 files, 0 MB copied
01.17 16:43.18| {4JRa} Auto-version change. Job: 4.0 client config: 1.0
01.17 16:43.18| ERR - {4JRa} No right version of render application found. Job: v4.x Client executable: v1.x;; (p:_cJobThread::startNewJob) rrClient L 7.0.b8q+6.2 [439dcd,0,,,|5419c321,,,,|5b702fbd,,,,145|]
01.17 16:43.18| ERR - {4JRa} Config ID -1 Found: 'C:\RR_localdata\renderer_exe\arnold\win_x64\Arnold-*\bin\kick.exe';; (p:_cJobThread::startNewJob) rrClient L 7.0.b8q+6.2 [439dcd,0,,,|5419c321,,,,|5b702fbd,,,,145|]
01.17 16:43.18| Sending client status '{4JRa} Render Crashed Permanentely'

it seems that i'm almost there.....

Looking at the version error, I'm running SitoA2.10, Arnold 4.016.0. I created the folder and coped the bin file in there. This is alos correctly copied to the local folder on the c:\ drive btw.

maybe that helps..
Back to top
View user's profile Send private message

schoenberger
Site Admin


Joined: 02 Mar 2005
Posts: 3786

PostPosted: Fri Jan 17, 2014 5:02 pm    Post subject: Reply with quote

Hi

You need to install Arnold Standalone, not SitoA or MtoA to render .ass files.

And then copy the Sitoa shader dlls into Arnold Standalone (not sure if they are included in the standalone package)
_________________
Holger Schönberger
Binary Alchemy - digital materialization
Back to top
View user's profile Send private message Send e-mail

robw



Joined: 14 Sep 2007
Posts: 15
Location/Company/Country: Amsterdam

PostPosted: Fri Jan 17, 2014 5:09 pm    Post subject: Reply with quote

just read that, i'm fully in friday afternoon mode it seems.
will dl the standalone, and test some more.

thanks for all the help!!

rob
Back to top
View user's profile Send private message

schoenberger
Site Admin


Joined: 02 Mar 2005
Posts: 3786

PostPosted: Fri Jan 17, 2014 5:11 pm    Post subject: Reply with quote

Updated help files:

By default Arnold is configured to use a Shared Executable.

Important Note:
You need to install Arnold Standalone, not SitoA/MtoA/HtoA.

To setup Arnold, please follow these steps.
Note: this description is for Arnold 3.1.1.0 and windows x64, please modify regarding your OS and version

Copy your Arnold folder to
[RR]\render_apps\renderer_exe\arnold\win_x64\Arnold-3.1.1.0\
You probably should only copy the \bin folder to keep the file count low.
Edit [RR]\render_apps\_setenv\win\arnold.bat, remove the comment ('rem') and set your license server name.


SitoA/MtoA/HtoA:
If your .ass files have been exported by SitoA/MtoA/HtoA, then you need to copy the sahder dlls from your SitoA/MtoA/HtoA installation into Arnold Standalone.
For example SitoA:

Copy from the folder
[YourWorkgroup]\Addons\SItoA\Application\Plugins\bin\nt-x86-64\
the files
sitoa.dll
sitoa_curves_proc.dll
sitoa_shaders.dll
into
[RR]\render_apps\renderer_exe\arnold\win_x64\Arnold-3.1.1.0\bin
_________________
Holger Schönberger
Binary Alchemy - digital materialization
Back to top
View user's profile Send private message Send e-mail

robw



Joined: 14 Sep 2007
Posts: 15
Location/Company/Country: Amsterdam

PostPosted: Fri Jan 17, 2014 5:18 pm    Post subject: Reply with quote

Hi,

I've seen that, and set Arnold up in:
\\Rwserver\Apps\RoyalRender\render_apps\renderer_exe\arnold\win_x64\Arnold-4.0.16.0\bin\nt-x86-64\
This folder contains kick.exe and the sitoa.dll files

This is also coped over and mirrored locally:
C:\RR_localdata\renderer_exe\arnold\win_x64\Arnold-4.0.16.0\bin\nt-x86-64\

the arnold batfile in:
\\Rwserver\Apps\RoyalRender\render_apps\_setenv\win\
reflects the licenseport@server as stated in the lic
Back to top
View user's profile Send private message

schoenberger
Site Admin


Joined: 02 Mar 2005
Posts: 3786

PostPosted: Fri Jan 17, 2014 5:28 pm    Post subject: Reply with quote

Have they changed their folder structure?
Arnold-4.0.16.0\bin\nt-x86-64\kick.exe
As my Arnold-4.0.9.1 standalone contains
Arnold-4.0.16.0\bin\kick.exe

There is no nt-x86-64
_________________
Holger Schönberger
Binary Alchemy - digital materialization
Back to top
View user's profile Send private message Send e-mail

robw



Joined: 14 Sep 2007
Posts: 15
Location/Company/Country: Amsterdam

PostPosted: Fri Jan 17, 2014 5:45 pm    Post subject: Reply with quote

Hi,

A couple of versions ago, they changed it to the path structure of a addon:
\\Rwserver\xsiwg\SitoA2100_2013\Addons\SItoA\Application\Plugins\bin\nt-x86-64\

before that it was:
\\Rwserver\xsiwg\SItoA240_2011\Addons\SItoA\Application\bin\nt-x86-64\

Does that make any sense?
Back to top
View user's profile Send private message

schoenberger
Site Admin


Joined: 02 Mar 2005
Posts: 3786

PostPosted: Fri Jan 17, 2014 6:46 pm    Post subject: Reply with quote

That is SitoA. Arnold Standalone does not have an nt-x86-64. Please remove the folder.
Just bin\kick.exe
_________________
Holger Schönberger
Binary Alchemy - digital materialization
Back to top
View user's profile Send private message Send e-mail

robw



Joined: 14 Sep 2007
Posts: 15
Location/Company/Country: Amsterdam

PostPosted: Sat Jan 18, 2014 3:57 pm    Post subject: Reply with quote

Hi,
Rendering now starts, but aborts, steps to next frame, aborts again when rendering the .ass sequence...

01.18 14:50.19| rrClient L 7.0.b8q rrVer7.0.b8q+6.2
01.18 14:50.19| running in local copy mode C:\Users\rob\AppData\Local\Temp\rrbin\
01.18 14:50.19| shared RR root is \\Rwserver\Apps\RoyalRender\
01.18 14:50.19| ERR - No license file (or not allowed to read file)!
01.18 14:50.23| Time Zone 01:00.00
01.18 14:50.23| rrClient L 7.0.b8q rrVer7.0.b8q+7.2
01.18 14:50.23| ----- ----- ----- ----- ----- ----- ----- init done ----- ----- ----- ----- ----- ----- -----
01.18 14:50.23| Client is running on Win7_sp1 x64 12(HT)x4.1 Intel 32.2Ghz
01.18 14:50.23| Client machine is running since 00:51.09
01.18 14:50.25| Clear all local render out folder 'C:\RR_localdata\renderout\'...
01.18 14:50.25| Clear all local temp folder 'C:\RR_localdata\temp\'...
01.18 14:50.27| List Processes (minCore=15% ( 1.2% total))

01.18 14:50.27| WRN - System cannot be checked! Privilege 'Debug Programs' is missing for user 'rob' Please see Help/rrTerms/User for rrService
01.18 14:50.27| User logged in: rob
01.18 14:50.27| User login change: 'rob'
01.18 14:50.27| DailyExecute: Clearing...C:\RR_localdata\temp\ (files older than 01.18 08:50.27)
01.18 14:50.27| DailyExecute: Clearing...C:\RR_localdata\cachedscenes\
01.18 14:50.27| DailyExecute: LocalTextureFreeDriveSpace...
01.18 14:50.27| DailyExecute: delete .txt logs in C:\RR_localdata\...
01.18 14:50.28| WRN - Server connection took 1.06s
01.18 14:50.48| Sending client status 'Idle'
01.18 14:51.28| {0PN} Job Received: {0PN} RowuMedia|Arnold|--|nes \ Default_Pass_Main.<FN3>
01.18 14:51.28| {0PN} Rendering Job 50-57,1
01.18 14:51.28| {0PN} Rendering to: C:\RR_localdata\renderout\A\Render_Pictures\vanduin_anim_modellen_Los\Default_Pass\Main\Default_Pass_Main.
01.18 14:51.29| {0PN} Executable copy: start sync... '\\Rwserver\Apps\RoyalRender\render_apps\renderer_exe\arnold\win_x64\' => 'C:\RR_localdata\renderer_exe\arnold\win_x64\'
01.18 14:51.29| {0PN} Executable copy: 0 files, 0 MB copied
01.18 14:51.29| {0PN} Auto-version change. Job: 4.0 client config: 1.0
01.18 14:51.30| {0PN} Starting 1 Job instances... {0PN} RowuMedia|Arnold|--|nes \ Default_Pass_Main.<FN3>
01.18 14:51.32| {0PN} Render task done.
01.18 14:51.32| frameStats start
01.18 14:51.32| frameStats loaded
01.18 14:51.32| frameStats addFrames done
01.18 14:51.32| frameStats saveToFile
01.18 14:51.33| {0PN} Job was aborted: {0PN} RowuMedia|Arnold|--|nes \ Default_Pass_Main.<FN3>
01.18 14:51.34| Sending client status '{0PN} Render Aborted'
01.18 14:51.34| {0PN} Job Received: {0PN} RowuMedia|Arnold|--|nes \ Default_Pass_Main.<FN3>
....


So I tried rendering from within Softimage with the workstation plugins, to see if I can narow down the issues, and it seems RR cannot find the Arnold parameters.

Sorry for the long log:

7| >XSIBatch -processing -thread 12 -script "//Rwserver/Apps/RoyalRender/render_apps/scripts/kso_softimage.py" -lang Python -main rrStart -args -argAll " PyModPath: \\Rwserver\Apps\RoyalRender\render_apps/scripts, SName: \\RWSERVER\Projects\RowuMedia\3D\XSI\vanduin\Scenes\vanduin_anim_modellen_Los.scn, Db: \\RWSERVER\Projects\RowuMedia\3D\XSI\vanduin\, Pass: test, Camera: CameraAnim, SkipFrame: false , FName: C:\RR_localdata\renderout\A\Render_Pictures\vanduin_anim_modellen_Los\test\Main\<Layer>_Main. , FExt: .exr , FrStart: 1, FrEnd: 45, FrStep: 44 , FrOffset: 0 , Verbose: 0, KSOMode: true, KSOPort: 7774 "
R 8|
R 9| rrErr: Initialize Mental Ray: Elapsed time (ms): 22.39
R 10| rrErr: Load Command Definitions: Elapsed time (ms): 25.85
R 11| rrErr: Project List Initialization: Elapsed time (ms): 6.56
R 12|
R 13| =======================================================
R 14| Autodesk Softimage 11.1.57.0
R 15| =======================================================
R 16|
R 17|
R 18| rrErr: Scan for Custom SPDLs: Elapsed time (ms): 58.00
R 19| rrErr: Loading User plug-ins: Elapsed time (ms): 0.62
R 20| rrErr: Loading User addon plug-ins: Elapsed time (ms): 0.26
R 21| rrErr: Loading Workgroup plug-ins: Elapsed time (ms): 14.22
R 22| rrErr: Loading Workgroup addon plug-ins: Elapsed time (ms): 8.26
R 23| rrErr: Loading Factory plug-ins: Elapsed time (ms): 295.63
R 24|
R 25| License information: using [Processing]
R 26|
R 27| rrErr: Loading Factory addon plug-ins: Elapsed time (ms): 1823.14
R 28| rrErr: Loading setup plug-ins: Elapsed time (ms): 0.01
R 29|
R 30| rrErr: XSI Init: Elapsed time (s): 5.63
R 31|
R 32| COMMAND: -processing -thread 12 -script "//Rwserver/Apps/RoyalRender/render_apps/scripts/kso_softimage.py" -lang Python -main rrStart -args -argAll " PyModPath: \\Rwserver\Apps\RoyalRender\render_apps/scripts, SName: \\RWSERVER\Projects\RowuMedia\3D\XSI\vanduin\Scenes\vanduin_anim_modellen_Los.scn, Db: \\RWSERVER\Projects\RowuMedia\3D\XSI\vanduin\, Pass: test, Camera: CameraAnim, SkipFrame: false , FName: C:\RR_localdata\renderout\A\Render_Pictures\vanduin_anim_modellen_Los\test\Main\<Layer>_Main. , FExt: .exr , FrStart: 1, FrEnd: 45, FrStep: 44 , FrOffset: 0 , Verbose: 0, KSOMode: true, KSOPort: 7774 "
R 33| ' INFO : ' 15:50.50 rrSI :
R 34| ' INFO : ' 15:50.50 rrSI : Flag sname : '\\RWSERVER\Projects\RowuMedia\3D\XSI\vanduin\Scenes\vanduin_anim_modellen_Los.scn'
R 35| ' INFO : ' 15:50.50 rrSI : Flag ksomode : 'true'
R 36| ' INFO : ' 15:50.50 rrSI : Flag ksoport : '7774'
R 37| ' INFO : ' 15:50.50 rrSI : Flag db : '\\RWSERVER\Projects\RowuMedia\3D\XSI\vanduin\'
R 38| ' INFO : ' 15:50.50 rrSI : Flag pass : 'test'
R 39| ' INFO : ' 15:50.50 rrSI : Flag skipframe : 'false'
R 40| ' INFO : ' 15:50.50 rrSI : Flag fname : 'C:\RR_localdata\renderout\A\Render_Pictures\vanduin_anim_modellen_Los\test\Main\<Layer>_Main.'
R 41| ' INFO : ' 15:50.50 rrSI : Flag fext : '.exr'
R 42| ' INFO : ' 15:50.50 rrSI : Flag frstart : '1'
R 43| ' INFO : ' 15:50.50 rrSI : Flag frend : '45'
R 44| ' INFO : ' 15:50.50 rrSI : Flag frstep : '44'
R 45| ' INFO : ' 15:50.50 rrSI : Flag froffset : '0'
R 46| ' INFO : ' 15:50.50 rrSI : Flag camera : 'CameraAnim'
R 47| ' INFO : ' 15:50.50 rrSI : Flag verbose : '0'
R 48| ' INFO : ' 15:50.50 rrSI : Flag pymodpath : '\\Rwserver\Apps\RoyalRender\render_apps/scripts'
R 49| ' INFO : ' 15:50.50 rrSI : Set project to '\\RWSERVER\Projects\RowuMedia\3D\XSI\vanduin\'...
R 50| ' INFO : ' 15:50.50 rrSI : Active Project: \\RWSERVER\Projects\RowuMedia\3D\XSI\vanduin
R 51| ' INFO : ' 15:50.50 rrSI : Loading Scene '\\RWSERVER\Projects\RowuMedia\3D\XSI\vanduin\Scenes\vanduin_anim_modellen_Los.scn'...
R 52| >Loading: \\RWSERVER\Projects\RowuMedia\3D\XSI\vanduin\Scenes\vanduin_anim_modellen_Los.scn...
R 53| ' INFO : 4034 - Loaded scene was created with build number: 11.1.57.0 - compatibility version: 1100
R 54| ' ERROR : 2356 - This plug-in is not installed: arnold_parameters
R 55| ' ERROR : 2356 - This plug-in is not installed: Arnold Render Options
R 56|
R 57| OpenScene "\\RWSERVER\Projects\RowuMedia\3D\XSI\vanduin\Scenes\vanduin_anim_modellen_Los.scn", False
R 58| ' INFO : ' 15:50.51 rrSI : Set project to '\\RWSERVER\Projects\RowuMedia\3D\XSI\vanduin\'...
R 59| ' INFO : ' 15:50.51 rrSI : Active Project: \\RWSERVER\Projects\RowuMedia\3D\XSI\vanduin
R 60| ' INFO : ' 15:50.51 rrSI : Set pass to 'test'
R 61| SetCurrentPass "Passes.test"
R 62| ' INFO : ' 15:50.51 rrSI : renderer used: 'Hardware Renderer'
R 63| ' INFO : ' 15:50.51 rrSI : Set renderer to CameraAnim
R 64| SetValue "Passes.test.Camera", "CameraAnim"
R 65| ' INFO : ' 15:50.51 rrSI : Set FrameSkipRendered to false
R 66| SetValue "Passes.test.FrameSkipRendered", "false"
R 67| SetValue "Passes.test.Main.Enabled", True
R 68| ' INFO : ' 15:50.51 rrSI : Set Filename to C:\RR_localdata\renderout\A\Render_Pictures\vanduin_anim_modellen_Los\test\Main\[Pass]_Main.[Frame ].exr
R 69| SetValue "Passes.test.Main.Filename", "C:\RR_localdata\renderout\A\Render_Pictures\vanduin_anim_modellen_Los\test\Main\[Pass]_Main.[Frame ].exr"
R 70| SetValue "Passes.test.mentalray.VerbosityLevel", "0"
R 71| ' INFO : ' 15:50.51 rrSI : Changing current frame to 1
R 72| SetValue "PlayControl.Current", 1
R 73| SceneRefresh
R 74| ' INFO : ' 15:50.51 rrSI : Scene init done, starting to render...
R 75| ' INFO : ' 15:50.51 rrSI : Scene load time: 0:00:00.917000 h:m:s.ms
R 76| ' INFO : ' 15:50.51 rrSI : Importing kso...
R 77| ' INFO : ' 15:50.51 rrSI : rrKSO startup...
R 78| ' INFO : ' 15:50.51 rrSI : rrKSO server started
R 79|
R 80| ' INFO :
R 81| ' INFO :
R 82| ' INFO :
R 83| ' INFO : ' 15:50.59 rrSI : rrKSONextCommand 'ksoRenderFrame (1, 45, 44 )
R 84| ' '
R 85| ' INFO : ' 15:50.59 rrSI : Changing scene frame to frame #1 ...
R 86| SetValue "PlayControl.Current", 1
R 87| SceneRefresh
R 88| ' INFO : ' 15:50.59 rrSI : Starting to render frame #1 ...
R 89| ' INFO : SAS Script Pass: 'p0' compiled successfully: 1 commands
R 90| ' SAS Script Technique: 'gp5vp_gp5fp' compiled successfully: 1 commands
R 91| ' SAS Script Pass: 'p0' compiled successfully: 1 commands
R 92| ' SAS Script Technique: 'gp4vp_gp4fp' compiled successfully: 1 commands
R 93| ' SAS Script Pass: 'p0' compiled successfully: 1 commands
R 94| ' SAS Script Technique: 'glslv_glslf' compiled successfully: 1 commands
R 95| '
R 96| ' INFO : SAS Script Pass: 'p0' compiled successfully: 1 commands
R 97| ' SAS Script Technique: 'gp5vp_gp5fp' compiled successfully: 1 commands
R 98| ' SAS Script Pass: 'p0' compiled successfully: 1 commands
R 99| ' SAS Script Technique: 'gp4vp_gp4fp' compiled successfully: 1 commands
R100| ' SAS Script Pass: 'p0' compiled successfully: 1 commands
R101| ' SAS Script Technique: 'glslv_glslf' compiled successfully: 1 commands
R102| '
R103| ' INFO : SAS Script Pass: 'p0' compiled successfully: 1 commands
R104| ' SAS Script Technique: 'gp5vp_gp5fp' compiled successfully: 1 commands
R105| ' SAS Script Pass: 'p0' compiled successfully: 1 commands
R106| ' SAS Script Technique: 'gp4vp_gp4fp' compiled successfully: 1 commands
R107| ' SAS Script Pass: 'p0' compiled successfully: 1 commands
R108| ' SAS Script Technique: 'glslv_glslf' compiled successfully: 1 commands
R109| '
R110| ' INFO : SAS Script Pass: 'p0' compiled successfully: 1 commands
R111| ' SAS Script Technique: 'gp5vp_gp5fp' compiled successfully: 1 commands
R112| ' SAS Script Pass: 'p0' compiled successfully: 1 commands
R113| ' SAS Script Technique: 'gp4vp_gp4fp' compiled successfully: 1 commands
R114| ' SAS Script Pass: 'p0' compiled successfully: 1 commands
R115| ' SAS Script Technique: 'glslv_glslf' compiled successfully: 1 commands
R116| '
R117|
R118| ' INFO : SAS Script Pass: 'p0' compiled successfully: 1 commands
R119| ' SAS Script Technique: 'gp5vp_gp5fp' compiled successfully: 1 commands
R120| ' SAS Script Pass: 'p0' compiled successfully: 1 commands
R121| ' SAS Script Technique: 'gp4vp_gp4fp' compiled successfully: 1 commands
R122| ' SAS Script Pass: 'p0' compiled successfully: 1 commands
R123| ' SAS Script Technique: 'glslv_glslf' compiled successfully: 1 commands
R124| '
R125| ' INFO : SAS Script Pass: 'p0' compiled successfully: 1 commands
R126| ' SAS Script Technique: 'gp5vp_gp5fp' compiled successfully: 1 commands
R127| ' SAS Script Pass: 'p0' compiled successfully: 1 commands
R128| ' SAS Script Technique: 'gp4vp_gp4fp' compiled successfully: 1 commands
R129| ' SAS Script Pass: 'p0' compiled successfully: 1 commands
R130| ' SAS Script Technique: 'glslv_glslf' compiled successfully: 1 commands
R131| '
R132|
R133| ' INFO : SAS Script Pass: 'p0' compiled successfully: 1 commands
R134| ' SAS Script Technique: 'gp5vp_gp5fp' compiled successfully: 1 commands
R135| ' SAS Script Pass: 'p0' compiled successfully: 1 commands
R136| ' SAS Script Technique: 'gp4vp_gp4fp' compiled successfully: 1 commands
R137| ' SAS Script Pass: 'p0' compiled successfully: 1 commands
R138| ' SAS Script Technique: 'glslv_glslf' compiled successfully: 1 commands
R139| '
R140| ' INFO : SAS Script Pass: 'p0' compiled successfully: 1 commands
R141| ' SAS Script Technique: 'gp5vp_gp5fp' compiled successfully: 1 commands
R142| ' SAS Script Pass: 'p0' compiled successfully: 1 commands
R143| ' SAS Script Technique: 'gp4vp_gp4fp' compiled successfully: 1 commands
R144| ' SAS Script Pass: 'p0' compiled successfully: 1 commands
R145| ' SAS Script Technique: 'glslv_glslf' compiled successfully: 1 commands
R146| '
R147| ' INFO : SAS Script Pass: 'p0' compiled successfully: 1 commands
R148| ' SAS Script Technique: 'gp5vp_gp5fp' compiled successfully: 1 commands
R149| ' SAS Script Pass: 'p0' compiled successfully: 1 commands
R150| ' SAS Script Technique: 'gp4vp_gp4fp' compiled successfully: 1 commands
R151| ' SAS Script Pass: 'p0' compiled successfully: 1 commands
R152| ' SAS Script Technique: 'glslv_glslf' compiled successfully: 1 commands
R153| '
R154|
R155| ' INFO : SAS Script Pass: 'p0' compiled successfully: 1 commands
R156| ' SAS Script Technique: 'gp5vp_gp5fp' compiled successfully: 1 commands
R157| ' SAS Script Pass: 'p0' compiled successfully: 1 commands
R158| ' SAS Script Technique: 'gp4vp_gp4fp' compiled successfully: 1 commands
R159| ' SAS Script Pass: 'p0' compiled successfully: 1 commands
R160| ' SAS Script Technique: 'glslv_glslf' compiled successfully: 1 commands
R161| '
R162| ' INFO : SAS Script Pass: 'p0' compiled successfully: 1 commands
R163| ' SAS Script Technique: 'gp5vp_gp5fp' compiled successfully: 1 commands
R164| ' SAS Script Pass: 'p0' compiled successfully: 1 commands
R165| ' SAS Script Technique: 'gp4vp_gp4fp' compiled successfully: 1 commands
R166| ' SAS Script Pass: 'p0' compiled successfully: 1 commands
R167| ' SAS Script Technique: 'glslv_glslf' compiled successfully: 1 commands
R168| '
R169| ' INFO : SAS Script Pass: 'p0' compiled successfully: 1 commands
R170| ' SAS Script Technique: 'gp5vp_gp5fp' compiled successfully: 1 commands
R171| ' SAS Script Pass: 'p0' compiled successfully: 1 commands
R172| ' SAS Script Technique: 'gp4vp_gp4fp' compiled successfully: 1 commands
R173| ' SAS Script Pass: 'p0' compiled successfully: 1 commands
R174| ' SAS Script Technique: 'glslv_glslf' compiled successfully: 1 commands
R175| '
R176| ' INFO : SAS Script Pass: 'p0' compiled successfully: 1 commands
R177| ' SAS Script Technique: 'gp5vp_gp5fp' compiled successfully: 1 commands
R178| ' SAS Script Pass: 'p0' compiled successfully: 1 commands
R179| ' SAS Script Technique: 'gp4vp_gp4fp' compiled successfully: 1 commands
R180| ' SAS Script Pass: 'p0' compiled successfully: 1 commands
R181| ' SAS Script Technique: 'glslv_glslf' compiled successfully: 1 commands
R182| '
R183| ' INFO : SAS Script Pass: 'p0' compiled successfully: 1 commands
R184| ' SAS Script Technique: 'gp5vp_gp5fp' compiled successfully: 1 commands
R185| ' SAS Script Pass: 'p0' compiled successfully: 1 commands
R186| ' SAS Script Technique: 'gp4vp_gp4fp' compiled successfully: 1 commands
R187| ' SAS Script Pass: 'p0' compiled successfully: 1 commands
R188| ' SAS Script Technique: 'glslv_glslf' compiled successfully: 1 commands
R189| '
R190| ' WARNING : 3070-REND-RenderPass - Type mismatch between shader and connection point.
R191| ' ERROR : 21000-REND-RenderPass - Unspecified failure
R192| RenderPass "Passes.test", , 1, 45, 44
R193| Command failed, returned -2147467259
R194| ' ERROR : Traceback (most recent call last):
R195| ' File "
R196| ' render_KSO(inPass,inFrStart,inFrEnd,inFrStep,inKSOPort)
R197| ' File "
R198| ' rrKSOStartServer(inKSOPort)
R199| ' File "
R200| ' exec (kso_tcp.rrKSONextCommand)
R201| ' File "<string>", line 1, in <module>
R202| ' File "
R203| ' xsi.renderpass (kso_global_inPass ,"", inFrStart,inFrEnd,inFrStep)
R204| ' File "<COMObject>", line 2, in renderpass
R205| ' COM Error: Unspecified error (0x-7fffbffb) - [line 90]
R206| ERROR - Script failed.
R207| FATAL - Script Aborted.
R208|
R209|
R210| ' INFO : Rendering pass 'test'...
R211| ' INFO : Rendering frame 1 (0.0% done)
R212| ' INFO : Characters has been unloaded.
R213| ' INFO : TransformUVsPlugin has been unloaded.
R214| ' INFO : polymatricksPlugin has been unloaded.
R215| ' INFO : FBX-XSI import/export Plug-in has been unloaded.
R216| ' INFO : Unfold3D Plugin has been unloaded.
R217|
R218|
R219| >"\\Rwserver\Apps\RoyalRender\bin\win\rrCheckexitcode.exe" 1 0 0 1
R220|
R221| +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
R222| +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
R223| ++++++++++++++++++++++++++++++++++++ Render Executable done +++++++++++++++++++++++++++++++++++
R224| ++++++++++++++++++++ Royal Render checks the return code of the executable ++++++++++++++++++++
R225| ++++++++++++++++++++++++++++++++++++++ 01.18. 15:51.05 +++++++++++++++++++++++++++++++++++++
R226| ++++ Executable returned 1 (0x 1) as exit code for frame 1.
R227| +++++ Executable crashed
R228| -
R229| +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
R230| ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
0| I7-PC rrClient console L 7.0.b8q rrVer7.0.b8q+7.2 DEMO
1| 15:51:05,04
2| Job ID: {0ZF}
3| ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
4|
5|
6|
7|
8|
9| Current time:01.18 15:51.07
10|
11|
12| Total processing time: 00:00.25
C 0| ************************* LOCAL RENDER INFORMATION *************************
C 1| Total render files found: 0
C 2| Files successful copied: 0
C 3| Files broken/not copied: 0
C 4| Total render files found (main pass only): 0
C 5| List of files: (C=copied R=successfully read X=Exr cropped F=image verify failed V=rrViewer cache created)
C 6| ************************* CLIENT REPORTS DURING THIS RENDER *************************
C 7|
C 8| Error in log file: ' error : 2356 - this plug-in is not installed: arnold_parameters
C 9|
C 10| Error in log file: ' error : 2356 - this plug-in is not installed: arnold_parameters
C 11|
C 12| Error in log file: ' error : 2356 - this plug-in is not installed: arnold render options
C 13|
C 14| Error in log file: ' error : 2356 - this plug-in is not installed: arnold render options
C 15|
C 16| Error in log file: ' error : 21000-rend-renderpass - unspecified failure
C 17|
C 18| Error in log file: ' error : 21000-rend-renderpass - unspecified failure
C 19|
C 20| Error in log file: ' error : traceback (most recent call last):
C 21|
C 22| Error in log file: ' error : traceback (most recent call last):
C 23|
C 24| Error in log file: ' com error: unspecified error (0x-7fffbffb) - [line 90]
C 25|
C 26| Error in log file: ' com error: unspecified error (0x-7fffbffb) - [line 90]
C 27|
C 28| Error in log file: error - script failed.
C 29|
C 30| Error in log file: error - script failed.
C 31|
C 32|
C 33| Job crashed


can't test anymore this weekend, but hoping the above will make some sense.....

rob
Back to top
View user's profile Send private message

schoenberger
Site Admin


Joined: 02 Mar 2005
Posts: 3786

PostPosted: Sat Jan 18, 2014 4:22 pm    Post subject: Reply with quote

Arnold:
The client application log does not help.
There has to be a reason in the render log.


Softimage:
You need to install Arnold in a location that is found by Softimage.
A few lines before Softimage starts the log shows the Workgroup path that is used by RR.
_________________
Holger Schönberger
Binary Alchemy - digital materialization
Back to top
View user's profile Send private message Send e-mail

robw



Joined: 14 Sep 2007
Posts: 15
Location/Company/Country: Amsterdam

PostPosted: Sun Jan 19, 2014 5:17 pm    Post subject: Reply with quote

Hi Holger,

After your comments on the workgroups, I rechecked all the appropriate batchfiles to see what was going on.

I'm happy to say a simple typo in _setenv/win/softimage.bat was preventing Arnold to be loaded in the string of workgroups I was setting. <blush>

I still do get some oddball error messages, but this do not prevent the renders to start.
There's also some errors on plugin scripts, but most of them seem to be loading anyway:

R 28| ' ERROR : <InspectObj>, This command can't be used in batch mode. - [line 3634 in C:\Program Files\Autodesk\Softimage 2013 SP1\Application\DSScripts\uixsiscripts.vbs]
R 29| ' ERROR : - [line 1263 in C:\Program Files\Autodesk\Softimage 2013 SP1\Application\DSScripts\uixsiscripts.vbs]
R 30| AddProp "Custom_parameter_list", "Scene_Root", siDefaultPropagation
R 31| Command failed, returned -2147418113
R 32| ' ERROR : - [line 62 in \\Rwserver\xsiwg\RWTools\Addons\agBend\Application\Plugins\agBabel.js]
R 33| ' INFO : agBend 2.1 has been installed.

So I tested both an exported .ass sequence and a 'straight from SI submit', both work just great now.

thanks for your tips and patience! Smile

rob
Back to top
View user's profile Send private message
Display posts from previous:   
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    www.BinaryAlchemy.de Forum Index -> old - RR Questions - v6.x All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
 
Documento sin título
 



Powered by phpBB © 2001, 2002 phpBB Group



Number of shameful bots caught by Anti-Spam ACP: 1667